Network Issues - Outage

Incident Report for University of Waterloo

Resolved

There are reports of wired network issues on Campus. The problem is under investigation.
Posted May 05, 2026 - 11:39 EDT

Investigating

There are reports of wired network issues on Campus. The problem is under investigation.
Posted May 05, 2026 - 10:18 EDT
This incident affected: Network (Wired Network).