BMH 3rd floor switch offline - Outage

Incident Report for University of Waterloo

Resolved

A 3rd floor BMH switch is offline. IST is investigating.
Posted Mar 09, 2026 - 08:36 EDT

Investigating

A 3rd floor BMH switch is offline. IST is investigating.
Posted Mar 09, 2026 - 07:43 EDT
This incident affected: Network (Wireless Network, Wired Network).