Enginnering 3 Network Switch Offline - Outage

Incident Report for University of Waterloo

Update

The switches are offline due to an unplanned power outage. Plant Operations is currently on site investigating the issue.
Posted May 19, 2026 - 09:41 EDT

Investigating

Two network switches on the third floor of E3 are currently offline.

IST is investigating.
Posted May 19, 2026 - 09:37 EDT
This incident affects: Network (Wired Network).