Issue with Atlassian Services - Degradation

Incident Report for University of Waterloo

Resolved

Resolved: IST has been notified by impacted users that the reported instability has improved.

Questions or concerns? Please email helpdesk@uwaterloo.ca.
Posted Oct 10, 2025 - 13:09 EDT

Update

What is happening? IST is aware that some users on their home internet network are experiencing issues accessing the university’s Atlassian sites. 

The vendor has advised that it appears the issue is impacting those utilizing Rogers network infrastructure and these users need to contact their internet provider. 

What do I need to do? If you are experiencing issues, contact your internet service provider to request they review the Atlassian URLs (uwaterloo.atlassian.net) to confirm they have not put a firewall/AC rule in place that is blocking the service.

Users who have access to a Remote Desktop, can utilize this service to access Atlassian on the campus network.
https://uwaterloo.atlassian.net/wiki/spaces/ISTKB/pages/262013067/Remote+Desktop+from+Windows+to+Windows

Questions or concerns? Please email helpdesk@uwaterloo.ca.
Posted Oct 09, 2025 - 09:33 EDT

Investigating

What is happening? IST is aware of degraded Atlassian services. IST is investigating with the vendor and will provide more information as available.

What is the impact? The full impact of degraded services is unknown. Users have reported issues loading sites and slow performance.

Questions or concerns? Please email helpdesk@uwaterloo.ca.
Posted Oct 08, 2025 - 09:49 EDT
This incident affected: Atlassian Products (Jira Service Management, Jira Software, Confluence).